Welcome to Our Community

Wanting to join the rest of our members? Feel free to sign up today.

Sign Up

05 pitbull Loud screeching noise from primary

Discussion in 'Transmission / Drive' started by Nate Smith, Oct 7, 2018.

  1. Nate Smith

    Nate Smith New Member

    Joined:
    Mar 27, 2018
    Messages:
    1
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    55422
    My Bike(s):
    Big Dog Chopper
    First Name:
    Naste
    Looking for advise.... First let me introduce myself to the Big Dog Community My name is Nate and I just bought my big dog about 4 months ago I have an 05 Pit bull 117CC And 6 speed Baker transmission.... So Now my question. I've been getting the loud screeching noise from the inside of my primary. So I took the primary Cover off in seen the the chain was loose also seen that the chain is hitting the inside of the outer primary cover.... So thinking that the chain was my problem I just Tighten it... But i'm having same problem.... any ideas
     
    francoblay1 likes this.
  2. Steven Proctor

    Joined:
    Mar 4, 2018
    Messages:
    116
    Likes Received:
    46
    Trophy Points:
    28
    Location:
    GA
    My Bike(s):
    '06 K9, '03 VTX1300R
    First Name:
    Steve
    Welcome to the forum from SE Ga. I am not sure, as I have an open primary. Do you have any pix? I recommend doing a search for this. Lots of great advice and How 2's.
     
  3. Billy the kid

    Billy the kid Well-Known Member
    Supporting Member

    Joined:
    Mar 20, 2010
    Messages:
    3,911
    Likes Received:
    2,510
    Trophy Points:
    113
    Location:
    Gunnison colorado
    My Bike(s):
    Bigdog Ridgeback 2006, 2010 Harley CVO ultra electra glide
    Your clutch hub nut has probably come loose
     
  4. pknowles

    pknowles Getting better by the day...---... GURU
    Supporting Member

    Joined:
    Jul 10, 2010
    Messages:
    7,686
    Likes Received:
    6,716
    Trophy Points:
    113
    Location:
    virginia
    My Bike(s):
    , 2012 CVO Streetglide, 07k9 MAKIN IT MY OWN
    First Name:
    paul
    Sure sounds like something came loose. Id you need a complete primary i still have all the parts that came off my 07 K9 when i installed the baker open primary.
     
  5. Fat_Bastard

    Fat_Bastard Active Member

    Joined:
    May 3, 2010
    Messages:
    417
    Likes Received:
    371
    Trophy Points:
    63
    Location:
    Route 66
    My Bike(s):
    2004 Big Dog Chopper, HD Fat Boy
    First Name:
    Title: "CRO" , Chief Riding Officer, SoCal riders group
    More than likely loose compensator nut and/or bad/broken compensator spring. That was the case on my 04 Chop... But also could be what others have said...
     
    francoblay1 and HMAN like this.
  6. PacoPetty

    PacoPetty Well-Known Member

    Joined:
    Mar 8, 2010
    Messages:
    1,377
    Likes Received:
    1,244
    Trophy Points:
    113
    Location:
    Martinsville,VA
    My Bike(s):
    2006 Bigdog Pitbull
    First Name:
    Andy
    Welcome and good luck with your repair
     
  7. pauldeepsea

    pauldeepsea Well-Known Member

    Joined:
    Jun 15, 2008
    Messages:
    4,531
    Likes Received:
    5,037
    Trophy Points:
    113
    Location:
    California
    My Bike(s):
    2004 Pitbull/ridgeback , 2006 big bear sled 300
    First Name:
    Paul
    You may need to adjust your primary chain tension
     
  8. Marky-Marc

    Marky-Marc Well-Known Member

    Joined:
    Apr 8, 2014
    Messages:
    1,237
    Likes Received:
    1,984
    Trophy Points:
    113
    Location:
    Des Moines, IA
    My Bike(s):
    2005 Big Dog Ridgeback
    First Name:
    Marc
    Nate, your best bet is to pull your primary cover back off, check your clutch hub nut, sprocket nut, maybe even remove the clutch basket and have a look at everything and clean it. After checking everything, reassemble with correct torque specs and loctite. Did you see any shavings in the primary? On the primary drain plug? Are all 6 of your transmission bolts still in? Where were the markings on the inside of your primary cover?

    Post some pictures of the primary cover markings or of the inside of your primary...someone may just notice something that's not right.
     
    Billy the kid and chubs like this.
  9. woodbutcher

    woodbutcher Mr. Old Fart member #145
    Staff Member Supporting Member

    Joined:
    Aug 16, 2007
    Messages:
    10,642
    Likes Received:
    4,264
    Trophy Points:
    113
    Location:
    hilton head is., sc
    My Bike(s):
    black cherry '07 K9
    First Name:
    Tom
    there was a redesign of the clutch carrier around late '07/'08 due to cracking. would certainly be a good idea to remove the clutch and check that for problems. could be the carrier scrubbing on the inner primary.
     
    Billy the kid likes this.

Share This Page