Welcome to Our Community

Wanting to join the rest of our members? Feel free to sign up today.

Sign Up

2001 Wolf Speedometer

Discussion in 'Vintage Big Dogs' started by Chuck Hughes, May 7, 2018.

  1. Chuck Hughes

    Chuck Hughes Member

    Joined:
    Jul 26, 2017
    Messages:
    98
    Likes Received:
    90
    Trophy Points:
    18
    Location:
    Bechtelsville PA
    My Bike(s):
    01 Big Dog Wolf, 02 Chopper Sportster
    First Name:
    Chuck
    Hey guys, is there a way to replace the lights inside the speedometer or does the whole thing speedometer have to be replaced? Just noticed the other morning riding to work that the lights weren't working.
     
    chubs likes this.
  2. FrankBDPS

    FrankBDPS Well-Known Member

    Joined:
    Sep 7, 2013
    Messages:
    3,341
    Likes Received:
    3,109
    Trophy Points:
    113
    Location:
    North Lawrence,Ohio
    My Bike(s):
    2ooo ProSport 1997 Honda Night Hawk
    First Name:
    Frank
    Chuck, if all the lights quit working at the same time you may have a broken wire or bad connection someplace. If you take the dash apart handle it with care. They are thin fiberglass and are no longer available. Check the plug on the back of the speedometer. It needs both a hot and a ground running to it. Good luck.
     
    Chuck Hughes and chubs like this.
  3. Chuck Hughes

    Chuck Hughes Member

    Joined:
    Jul 26, 2017
    Messages:
    98
    Likes Received:
    90
    Trophy Points:
    18
    Location:
    Bechtelsville PA
    My Bike(s):
    01 Big Dog Wolf, 02 Chopper Sportster
    First Name:
    Chuck
    Thanks Frank. That last sentence in my original post was supposed to say the running light isn't working either. I still have brake light, and headlight, but I noticed my turn signal automatic shutoffs arent working either. I have to manually turn them off
     
  4. BigDogRick

    BigDogRick Active Member

    Joined:
    Sep 16, 2012
    Messages:
    695
    Likes Received:
    890
    Trophy Points:
    93
    Location:
    Phoenix, AZ
    My Bike(s):
    2000 Big Dog Vintage Classic, 2004 HD Fatboy, 2008 Jeep Rubicon, 1972 VW Bus
    First Name:
    Rick
    Frank is right about the pin connector into the back of your speedo. It is a five wire pin that includes power and ground and a pair of wires going to your transmission sensor carrying signal there and back (I believe the 01 Wolf would still have the same setup as my 2000 Vintage Classic). The other wire talks to the relay circuit in your Thunderheart Module that acts as a traditional flasher relay. Before you overthink any of the electronics, check the condition and connection of all five of those wires. The light, on the other hand, in your speedo could be a broken solder point on the speedo circuit board has several potential causes - one of which may be a poor connection of the power wire in the said five pin connector. Start there. Do you have the Dakota Digital VDO speedo?
     
    chubs and pknowles like this.
  5. Chuck Hughes

    Chuck Hughes Member

    Joined:
    Jul 26, 2017
    Messages:
    98
    Likes Received:
    90
    Trophy Points:
    18
    Location:
    Bechtelsville PA
    My Bike(s):
    01 Big Dog Wolf, 02 Chopper Sportster
    First Name:
    Chuck
    This is the speedo I have. My lighting issues have been fixed, except for the speedo light. Really don't wanna have to replace the speedo, cause that will change my mileage reading.
     

    Attached Files:

    chubs likes this.
  6. BigDogRick

    BigDogRick Active Member

    Joined:
    Sep 16, 2012
    Messages:
    695
    Likes Received:
    890
    Trophy Points:
    93
    Location:
    Phoenix, AZ
    My Bike(s):
    2000 Big Dog Vintage Classic, 2004 HD Fatboy, 2008 Jeep Rubicon, 1972 VW Bus
    First Name:
    Rick
    Mr. Wright has been known to fix lights in speedos that simply had a soldered diode come loose on the circuit board. I don't know if he has done one of these VDOs (that's what you and I have). Its programmable and has a nice calibration feature. But I would really check the five pin connector in the back for an easy trouble shoot.
     
    chubs likes this.
  7. Chuck Hughes

    Chuck Hughes Member

    Joined:
    Jul 26, 2017
    Messages:
    98
    Likes Received:
    90
    Trophy Points:
    18
    Location:
    Bechtelsville PA
    My Bike(s):
    01 Big Dog Wolf, 02 Chopper Sportster
    First Name:
    Chuck
    I did check the 5 pin connector, but even if it was that, wouldn't it affect more than just the light? Would the whole speedo not work properly?
     
  8. BigDogRick

    BigDogRick Active Member

    Joined:
    Sep 16, 2012
    Messages:
    695
    Likes Received:
    890
    Trophy Points:
    93
    Location:
    Phoenix, AZ
    My Bike(s):
    2000 Big Dog Vintage Classic, 2004 HD Fatboy, 2008 Jeep Rubicon, 1972 VW Bus
    First Name:
    Rick
    I have had just one pin come loose a couple times.


    Sent from my iPad using Tapatalk Pro
     
    Chuck Hughes likes this.
  9. francoblay1

    francoblay1 The Spaniard

    Joined:
    Aug 14, 2011
    Messages:
    15,325
    Likes Received:
    12,560
    Trophy Points:
    113
    Location:
    LĀ“Escala, 17130 Spain
    My Bike(s):
    K9 (2006)
    First Name:
    Franco
    [​IMG]
     

Share This Page