Welcome to Our Community

Wanting to join the rest of our members? Feel free to sign up today.

Sign Up

2007 bulldog starting problems

Discussion in 'EFI Topics' started by willywill4765, Jan 27, 2018.

  1. willywill4765

    willywill4765 Member

    Joined:
    Mar 16, 2017
    Messages:
    32
    Likes Received:
    27
    Trophy Points:
    18
    Location:
    US
    Okay I have searched on this site for the last 2 hours. Bike Road great all summer, the weather has been decent the last week in the 50s, when to start bike it will kick over but cuts out. Hazard flashing lights come on, check engine light comes on, while trying to start it and puffs of smoke come out of the air cleaner. Using non ethanol gas, batteries charged, plugs are good change them anyway just to double-check. Any help would be greatly appreciated

    Sent from my SM-G900P using Tapatalk
     
  2. Reddickracing

    Reddickracing Active Member

    Joined:
    Jun 9, 2017
    Messages:
    219
    Likes Received:
    256
    Trophy Points:
    63
    Location:
    Louisiana
    My Bike(s):
    2006 K9, 07 Streetbob
    First Name:
    Jeff
    If my bike struggles to turn over the hazards will flash and will stop trying to turn over. I turn the key off and it resets, sometimes it cranks and sometimes it does it again. I put a new battery in which helped tremendously but I also found out my compression releases are not staying down but a sec and a half. Bout to replace them in the next few weeks. Idk if that helps you are not
     
  3. TapioK

    TapioK Well-Known Member
    Supporting Member

    Joined:
    Nov 23, 2011
    Messages:
    2,948
    Likes Received:
    4,725
    Trophy Points:
    113
    Location:
    Naples, FL / Finland
    My Bike(s):
    K9 -08, Chopper -03, Fat Boy (-97), BMW 1150GS -95
    First Name:
    Tapio
    Hazards also flash and horn tries to honk when there is not enough voltage on battery, did you check the voltage while pushing start?
     
    Srodden likes this.
  4. TapioK

    TapioK Well-Known Member
    Supporting Member

    Joined:
    Nov 23, 2011
    Messages:
    2,948
    Likes Received:
    4,725
    Trophy Points:
    113
    Location:
    Naples, FL / Finland
    My Bike(s):
    K9 -08, Chopper -03, Fat Boy (-97), BMW 1150GS -95
    First Name:
    Tapio
    If I remember correctly the compression releases are originally supposed to stay open about that time. Just enough to get over first pressure... some have rewired them to stay open as long as starter is running. There is a how to somewhere...Sorry I don’t have time to look for it now
     
  5. Reddickracing

    Reddickracing Active Member

    Joined:
    Jun 9, 2017
    Messages:
    219
    Likes Received:
    256
    Trophy Points:
    63
    Location:
    Louisiana
    My Bike(s):
    2006 K9, 07 Streetbob
    First Name:
    Jeff
    Yea my horn would try to make a sound too. Like I said when it put the new Throttle X 500 CCA battery in it helped a lot. I was told on here that the releases are supposed to stay down until it cranks idk. But they are original and gonna replace them any way.
     
  6. willywill4765

    willywill4765 Member

    Joined:
    Mar 16, 2017
    Messages:
    32
    Likes Received:
    27
    Trophy Points:
    18
    Location:
    US
    Thanks I will try that when I get home and check the volts on the battery

    Sent from my SM-G900P using Tapatalk
     
  7. BWG56

    BWG56 Guru

    Joined:
    Jul 29, 2008
    Messages:
    20,921
    Likes Received:
    38,266
    Trophy Points:
    113
    Location:
    USA
    My Bike(s):
    Big Dog, SpyderF3
    First Name:
    Ker
    You are correct.:old2:as long as the start button is on.
     
    dentdude36 and Reddickracing like this.
  8. Reddickracing

    Reddickracing Active Member

    Joined:
    Jun 9, 2017
    Messages:
    219
    Likes Received:
    256
    Trophy Points:
    63
    Location:
    Louisiana
    My Bike(s):
    2006 K9, 07 Streetbob
    First Name:
    Jeff
    I have also learned that a battery will show charged and good and still have a dead cell which lowers cca
     
    Srodden, dentdude36 and BWG56 like this.
  9. Griffit

    Griffit New Member

    Joined:
    Nov 19, 2017
    Messages:
    1
    Likes Received:
    2
    Trophy Points:
    3
    Location:
    ohio
    My Bike(s):
    classic chopper
    First Name:
    Bill
    a weak battery will cause those issues, modern electronics need power, you could get by with it if it had points, their not as demanding on an electrical system...
     
    Srodden and Reddickracing like this.
  10. Th3InfamousI

    Supporting Member

    Joined:
    Sep 26, 2009
    Messages:
    10,672
    Likes Received:
    15,902
    Trophy Points:
    113
    Location:
    Texas
    My Bike(s):
    04 Ridgeback & 07 K9
    First Name:
    Eric
    I think that was an upgrade if you ditched the EHC. If memory serves me right the original EHC just gave them juice for 1.5 seconds. MoeSpeeds did a how to on wiring them to the solenoid wire.

    Sent from my 2PS64 using Tapatalk
     
    TapioK and Reddickracing like this.
  11. willywill4765

    willywill4765 Member

    Joined:
    Mar 16, 2017
    Messages:
    32
    Likes Received:
    27
    Trophy Points:
    18
    Location:
    US
    Yes the voltage went down when I tried to start it it showed 12.48 and then when I try to start it it drop down to 7 to 8 and 1/2. It was a new battery the beginning of Summer did not have it on a trickle charge, but charged it with a regular battery charger once a month maybe I need to get a trickle charger or Tender

    Sent from my SM-G900P using Tapatalk
     
  12. TapioK

    TapioK Well-Known Member
    Supporting Member

    Joined:
    Nov 23, 2011
    Messages:
    2,948
    Likes Received:
    4,725
    Trophy Points:
    113
    Location:
    Naples, FL / Finland
    My Bike(s):
    K9 -08, Chopper -03, Fat Boy (-97), BMW 1150GS -95
    First Name:
    Tapio
    That POS is dead. Get a new one, most likely it still has warranty
     
    Reddickracing likes this.
  13. Reddickracing

    Reddickracing Active Member

    Joined:
    Jun 9, 2017
    Messages:
    219
    Likes Received:
    256
    Trophy Points:
    63
    Location:
    Louisiana
    My Bike(s):
    2006 K9, 07 Streetbob
    First Name:
    Jeff
    Look up "What to do if starter wont turn" by Moespeeds, its prob the thread that Eric is referring to. I looked at it briefly and looks to be very informative.
     
  14. willywill4765

    willywill4765 Member

    Joined:
    Mar 16, 2017
    Messages:
    32
    Likes Received:
    27
    Trophy Points:
    18
    Location:
    US
    Yeah it should be under warranty you think I put it on the charger overnight and then check it will do any good

    Sent from my SM-G900P using Tapatalk
     
  15. dentdude36

    dentdude36 Guru

    Joined:
    Nov 9, 2015
    Messages:
    8,626
    Likes Received:
    19,691
    Trophy Points:
    113
    Location:
    Suburbs of Buffalo NY
    My Bike(s):
    2007 K9
    First Name:
    Kevin
    http://www.bigdogbiker.com/posts/843858/
     
  16. BWG56

    BWG56 Guru

    Joined:
    Jul 29, 2008
    Messages:
    20,921
    Likes Received:
    38,266
    Trophy Points:
    113
    Location:
    USA
    My Bike(s):
    Big Dog, SpyderF3
    First Name:
    Ker
    No not 1.5 seconds, the manual stated 1.0 seconds:Don the OEM
     
    dentdude36 likes this.
  17. Th3InfamousI

    Supporting Member

    Joined:
    Sep 26, 2009
    Messages:
    10,672
    Likes Received:
    15,902
    Trophy Points:
    113
    Location:
    Texas
    My Bike(s):
    04 Ridgeback & 07 K9
    First Name:
    Eric
    Haha I was just going off memory close enough you big bully! Lol

    Sent from my 2PS64 using Tapatalk
     
    BWG56 and dentdude36 like this.
  18. Th3InfamousI

    Supporting Member

    Joined:
    Sep 26, 2009
    Messages:
    10,672
    Likes Received:
    15,902
    Trophy Points:
    113
    Location:
    Texas
    My Bike(s):
    04 Ridgeback & 07 K9
    First Name:
    Eric
    Yep agreed 7-8v ain't gonna work just get a new battery.

    Sent from my 2PS64 using Tapatalk
     
    dentdude36 likes this.
  19. dentdude36

    dentdude36 Guru

    Joined:
    Nov 9, 2015
    Messages:
    8,626
    Likes Received:
    19,691
    Trophy Points:
    113
    Location:
    Suburbs of Buffalo NY
    My Bike(s):
    2007 K9
    First Name:
    Kevin
    Axel got back to me and informed me that with his ehc the compression releases are engaged as long as the start button is in use/pressed..... figured I'd share the info
     
  20. Th3InfamousI

    Supporting Member

    Joined:
    Sep 26, 2009
    Messages:
    10,672
    Likes Received:
    15,902
    Trophy Points:
    113
    Location:
    Texas
    My Bike(s):
    04 Ridgeback & 07 K9
    First Name:
    Eric
    That's good to know too! Sounds like all the new stuff has resolved a timing issue that BigDog thought up for no reason.

    Sent from my 2PS64 using Tapatalk
     
    dentdude36 likes this.

Share This Page