Welcome to Our Community

Wanting to join the rest of our members? Feel free to sign up today.

Sign Up

click click starter problems

Discussion in 'Help Wanted' started by chihuasbigdog, Mar 3, 2009.

  1. chihuasbigdog

    chihuasbigdog LATINAMERICAN AFFAIRS

    Joined:
    Dec 6, 2008
    Messages:
    1,061
    Likes Received:
    22
    Trophy Points:
    38
    Location:
    Chihuahua, Mexico !!!
    My Bike(s):
    K9
    First Name:
    Chili
    Yesterday my bike instead of starting, just clicks, click and click.
    I thought it was a problem with the solenoid, but I came to the bible of big dogs and read a thread with the same problem by BBChopper. (by the way, thanks bro)

    I sand both parts but my surprise was seeing that one part is missing from the upper contact.....
    here is the pic.

    I think it is due to normal use, but, where can I get this contact complete??? maybe the whole part???
    anyone can help me???????

    THANKS !!!
     

    Attached Files:

    chubs likes this.
  2. Night Train

    Night Train Member

    Joined:
    Feb 14, 2008
    Messages:
    176
    Likes Received:
    2
    Trophy Points:
    0
    Location:
    Mulvane, KS
    My Bike(s):
    2006 Harley Night Train
    First Name:
    Mike
    Call big dog customer support, I bet they could scrounge one up for you.
     
  3. LDO

    LDO The Cleaner
    Supporting Member

    Joined:
    Apr 8, 2007
    Messages:
    2,756
    Likes Received:
    29
    Trophy Points:
    48
    Location:
    P-Cola FL.
    My Bike(s):
    03 Mastiff
    [​IMG]

    bigger pic 4 ya!:D
     
  4. nymikeok

    nymikeok on the back wheel

    Joined:
    Aug 18, 2008
    Messages:
    328
    Likes Received:
    80
    Trophy Points:
    28
    Location:
    oklahoma
    My Bike(s):
    2008 ridgeback
    First Name:
    Mike
    If you have a good rebuild shop around they can do it. Same starter thats on a Toyota 4runner or something like that. They rebuilt the one on my 05. If you need a whole starter let me know. I bought one in case the rebuild didn't work that I would sell, its new unused.
     
  5. chihuasbigdog

    chihuasbigdog LATINAMERICAN AFFAIRS

    Joined:
    Dec 6, 2008
    Messages:
    1,061
    Likes Received:
    22
    Trophy Points:
    38
    Location:
    Chihuahua, Mexico !!!
    My Bike(s):
    K9
    First Name:
    Chili
    problem solved.... i ve bought a solenoid contact from a dodge, and it fits ok. my dog starts again!!!

    thanks to all.
     
  6. Slider

    Slider Active Member

    Joined:
    Mar 17, 2008
    Messages:
    639
    Likes Received:
    9
    Trophy Points:
    18
    Location:
    Draper, Utah
    My Bike(s):
    "EHC"less 04 107 chopper; 07 RG; 06 Deluxe
    First Name:
    Gary
    That's good to know. :up:
     
  7. synfull

    synfull New Member

    Joined:
    Mar 9, 2009
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    My Bike(s):
    bulldog
    My bike is doing the same click click when I try to start. I have a 99 Bulldog. Can anyone tell me where the starter selenoid is so I can check it and where I can get one. I want to try this before the starter itself.

    Thanks
     
  8. rufroggy

    rufroggy Active Member

    Joined:
    Sep 29, 2007
    Messages:
    309
    Likes Received:
    3
    Trophy Points:
    0
    Location:
    Rowlett, Texas
    My Bike(s):
    2004 Big Dog Chopper
    Do you still have the starter? My '04 Chopper just took a shit (I think).. Went out to start, turned key, pushed run then start. Nothing but a click. The click is the compression release valves clicking..Nothing from the starter. Checked all connections, tightened the postive to the starter...Click..After reading post after post after post, I pulled the solenoid cover and checked the contacts. Didnt look too bad but a little pitted.. Took the emory cloth to them (as best as I could) and am now taking a break..Hopefully will put it back together in a few minutes..

    I also took my neighbors brand new battery off of his 05 Mastiff (on a tender) and threw it on mine. CLICK... Also, checked and found that I am getting power to the solenoid (green wire on mine) when I hit the start button and I have power to the "hot" side of she solenoid (from battery).. I,m thinking starter but it's not making any noise...
     
  9. rufroggy

    rufroggy Active Member

    Joined:
    Sep 29, 2007
    Messages:
    309
    Likes Received:
    3
    Trophy Points:
    0
    Location:
    Rowlett, Texas
    My Bike(s):
    2004 Big Dog Chopper

    Apparently I did something right. Put it all back together and she fired right up...:confused:
     
  10. rufroggy

    rufroggy Active Member

    Joined:
    Sep 29, 2007
    Messages:
    309
    Likes Received:
    3
    Trophy Points:
    0
    Location:
    Rowlett, Texas
    My Bike(s):
    2004 Big Dog Chopper
    OK check that..Got her running, turned her off after a few minutes, started the bitch 4-5 times no prob..however, number 6 and back to the same issue..light dims, the compression relief valves click but thats it..

    Battery?
     
  11. Gas Man

    Gas Man Cool isn't cheap
    Supporting Member Calendar Participant

    Joined:
    Apr 8, 2007
    Messages:
    15,047
    Likes Received:
    199
    Trophy Points:
    63
    Location:
    Metro Detoilet
    rufroggy

    Very much could be the battery. What's the voltage? Needs to be 12.8 sitting.

    And do you have the starting box on top of your battery. Little rectangle box with a couple of lights?
     
  12. rufroggy

    rufroggy Active Member

    Joined:
    Sep 29, 2007
    Messages:
    309
    Likes Received:
    3
    Trophy Points:
    0
    Location:
    Rowlett, Texas
    My Bike(s):
    2004 Big Dog Chopper
    Thanks Gas, I have not checked the voltage. No rectangle box on top of my 04.. The only box with lights is the EHC.. Just a lil baffled when I put my friend BRAND new battery on and got the same thing.. I did notice his CCA was only 310. Mine is a more 330 i think..
     
  13. Gas Man

    Gas Man Cool isn't cheap
    Supporting Member Calendar Participant

    Joined:
    Apr 8, 2007
    Messages:
    15,047
    Likes Received:
    199
    Trophy Points:
    63
    Location:
    Metro Detoilet
    I know its stupid... but...

    its got gas right?
     
  14. LARS

    LARS sippin & cruzin

    Joined:
    Dec 7, 2007
    Messages:
    1,593
    Likes Received:
    130
    Trophy Points:
    63
    Location:
    Fl.
    My Bike(s):
    02 WOLF
    I feel your pain,I bought a battery not 1yr old yet same thing happens,I could hit the start button 10 times in a row and get a click,on the 11th try,starts like a champ,and it's not all the time,some day's just starts right up,it's been on a tender all winter,battery tests fine,Im scratchin my head,don't mean to jack,but can't figure it out,good luck w/yours:cheers:
     
  15. MARV

    MARV Well-Known Member

    Joined:
    Aug 14, 2008
    Messages:
    1,937
    Likes Received:
    57
    Trophy Points:
    48
    Location:
    CENTRAL JERSEY
    My Bike(s):
    05 CHOP
    First Name:
    SUL
    make sure all cable connections at battery and starter are tight and clean.

    12.8 volts

    clean and square starter contacts
     
  16. pig pen

    pig pen Well-Known Member

    Joined:
    Mar 10, 2008
    Messages:
    1,219
    Likes Received:
    3
    Trophy Points:
    0
    Location:
    sandusky michigan
    My Bike(s):
    03 pitbull,69 and 81 sporsters
    First Name:
    John
    I have seen battery cables look good on the out side, but wire inside in poor condition. This could cause alkinds of intermiting trouble
     
  17. rufroggy

    rufroggy Active Member

    Joined:
    Sep 29, 2007
    Messages:
    309
    Likes Received:
    3
    Trophy Points:
    0
    Location:
    Rowlett, Texas
    My Bike(s):
    2004 Big Dog Chopper
    haha, yep full tank (minus whats leaking out the overflow tube)..some strange shit. Starts and then doesnt..about to piss me off. Im sure when I get to the problem it will be something simple....or at least I hope it is..lol
     
  18. rhinoevans

    rhinoevans Active Member

    Joined:
    Jun 21, 2008
    Messages:
    268
    Likes Received:
    2
    Trophy Points:
    16
    My Bike(s):
    2002 Pitbull
    Mine was clicking the other day also, except it was the starter relay (2002)
     
  19. rufroggy

    rufroggy Active Member

    Joined:
    Sep 29, 2007
    Messages:
    309
    Likes Received:
    3
    Trophy Points:
    0
    Location:
    Rowlett, Texas
    My Bike(s):
    2004 Big Dog Chopper
    My "click" is the compression release valves..No click at the starter...
     
  20. rufroggy

    rufroggy Active Member

    Joined:
    Sep 29, 2007
    Messages:
    309
    Likes Received:
    3
    Trophy Points:
    0
    Location:
    Rowlett, Texas
    My Bike(s):
    2004 Big Dog Chopper
    Chapter 2

    The Saga Continues;

    OK, go out, hook up cables to the truck and then the bike (truck not running) and try to start. Click (compression relief valves) nothing. Take the cables off, turn the key nothing.. Turn the key again BAM the bitch fires up.. WTF is goin on with this damn thing?

    Maybe an excuse to trade up on a Ridgeback???
     

Share This Page