Welcome to Our Community

Wanting to join the rest of our members? Feel free to sign up today.

Sign Up

Clutch problems

Discussion in 'General' started by Michael rogers, Oct 5, 2017.

  1. Michael rogers

    Joined:
    Sep 29, 2016
    Messages:
    24
    Likes Received:
    5
    Trophy Points:
    3
    Location:
    Massachusetts
    First Name:
    Mike
    I have a 08 big dog mastiff .my clutch lever almost solid its real hard to pull back and clutch wont disengage need help to figure out whats going on

    Sent from my SM-N920P using Tapatalk
     
  2. Th3InfamousI

    Supporting Member

    Joined:
    Sep 26, 2009
    Messages:
    10,378
    Likes Received:
    15,250
    Trophy Points:
    113
    Location:
    Texas
    My Bike(s):
    04 Ridgeback & 07 K9
    First Name:
    Eric
    Either your ball and ramp slipped or you got something stuck in your clutch plates.

    Take your primary cover off and dissassamble the clutch pack and look for broken parts. Take a look at the primary chain shoe it's plastic and can break.

    Sent from my 2PS64 using Tapatalk
     
    #2 Th3InfamousI, Oct 5, 2017
    Last edited: Oct 5, 2017
  3. Michael rogers

    Joined:
    Sep 29, 2016
    Messages:
    24
    Likes Received:
    5
    Trophy Points:
    3
    Location:
    Massachusetts
    First Name:
    Mike
    Thank you for replying back . Ill have to check that out

    Sent from my SM-N920P using Tapatalk
     
  4. Michael rogers

    Joined:
    Sep 29, 2016
    Messages:
    24
    Likes Received:
    5
    Trophy Points:
    3
    Location:
    Massachusetts
    First Name:
    Mike
    Really appreciate the info thank you

    Sent from my SM-N920P using Tapatalk
     
  5. Jwooky

    Jwooky Well-Known Member

    Joined:
    Dec 11, 2011
    Messages:
    1,556
    Likes Received:
    1,200
    Trophy Points:
    113
    Location:
    Oxford, MI
    My Bike(s):
    2008 Mastiff EFI
    First Name:
    JJ
    Before you open up the primary I would unscrew the cap where the push rod is and back it off to check the ball and ramp function independent of the clutch. If OK, then you know the clutch is seized.
     
    PROFLYER and bdm7250 like this.
  6. Michael rogers

    Joined:
    Sep 29, 2016
    Messages:
    24
    Likes Received:
    5
    Trophy Points:
    3
    Location:
    Massachusetts
    First Name:
    Mike
    Thank you ill check that first

    Sent from my SM-N920P using Tapatalk
     
  7. TapioK

    TapioK Well-Known Member
    Supporting Member

    Joined:
    Nov 23, 2011
    Messages:
    2,836
    Likes Received:
    4,530
    Trophy Points:
    113
    Location:
    Naples, FL / Finland
    My Bike(s):
    K9 -08, Chopper -03, Fat Boy (-97), BMW 1150GS -95
    First Name:
    Tapio
    Or the cable is about to break
     
    PROFLYER likes this.
  8. Michael rogers

    Joined:
    Sep 29, 2016
    Messages:
    24
    Likes Received:
    5
    Trophy Points:
    3
    Location:
    Massachusetts
    First Name:
    Mike
    I pulled of the primary cover and found a broken bolt i cant find where it came from . I pulled out all the clutch plates . But i noticed where i just pulled them out theirs a lot play [​IMG]

    Sent from my SM-N920P using Tapatalk
     
  9. Michael rogers

    Joined:
    Sep 29, 2016
    Messages:
    24
    Likes Received:
    5
    Trophy Points:
    3
    Location:
    Massachusetts
    First Name:
    Mike
    I send a video of what its doing because im not sure if its normal

    Sent from my SM-N920P using Tapatalk
     
  10. Unsprung

    Unsprung Well-Known Member
    Supporting Member

    Joined:
    May 18, 2015
    Messages:
    1,058
    Likes Received:
    2,157
    Trophy Points:
    113
    Location:
    Ruskin, FL
    My Bike(s):
    08 K9, 06 Hayabusa, (wife's ride)
    First Name:
    Gerald
    Chain looks loose, might want to check that too. Post a pic of the broken bolt like Paul said, someone may be able to tell you where it came from.
     
  11. Michael rogers

    Joined:
    Sep 29, 2016
    Messages:
    24
    Likes Received:
    5
    Trophy Points:
    3
    Location:
    Massachusetts
    First Name:
    Mike
    This is it[​IMG]

    Sent from my SM-N920P using Tapatalk
     
  12. Michael rogers

    Joined:
    Sep 29, 2016
    Messages:
    24
    Likes Received:
    5
    Trophy Points:
    3
    Location:
    Massachusetts
    First Name:
    Mike
    This is it[​IMG]

    Sent from my SM-N920P using Tapatalk
     
  13. Th3InfamousI

    Supporting Member

    Joined:
    Sep 26, 2009
    Messages:
    10,378
    Likes Received:
    15,250
    Trophy Points:
    113
    Location:
    Texas
    My Bike(s):
    04 Ridgeback & 07 K9
    First Name:
    Eric
    Chain is loose... And it looks very loose...lol

    Sent from my 2PS64 using Tapatalk
     
    Unsprung likes this.
  14. Th3InfamousI

    Supporting Member

    Joined:
    Sep 26, 2009
    Messages:
    10,378
    Likes Received:
    15,250
    Trophy Points:
    113
    Location:
    Texas
    My Bike(s):
    04 Ridgeback & 07 K9
    First Name:
    Eric
    That looms like a bolt that holds the inner primary on.....wondering if a lock tab wasn't put back

    Sent from my 2PS64 using Tapatalk
     
    HMAN and Unsprung like this.
  15. SomeTexan

    SomeTexan Member

    Joined:
    Oct 6, 2017
    Messages:
    130
    Likes Received:
    122
    Trophy Points:
    43
    Location:
    Godley Tx
    My Bike(s):
    05 Big Dog Ridgeback
    First Name:
    Adam
    Would that be a bolt for the guide or tensioner?
     
  16. Unsprung

    Unsprung Well-Known Member
    Supporting Member

    Joined:
    May 18, 2015
    Messages:
    1,058
    Likes Received:
    2,157
    Trophy Points:
    113
    Location:
    Ruskin, FL
    My Bike(s):
    08 K9, 06 Hayabusa, (wife's ride)
    First Name:
    Gerald
    The play may be a loose hub nut...
     
  17. Michael rogers

    Joined:
    Sep 29, 2016
    Messages:
    24
    Likes Received:
    5
    Trophy Points:
    3
    Location:
    Massachusetts
    First Name:
    Mike
    Thanks for the reply ill keep looking i still cant find a missing bolt

    Sent from my SM-N920P using Tapatalk
     
  18. Michael rogers

    Joined:
    Sep 29, 2016
    Messages:
    24
    Likes Received:
    5
    Trophy Points:
    3
    Location:
    Massachusetts
    First Name:
    Mike
    Whats the easiest way to get that out

    Sent from my SM-N920P using Tapatalk
     
  19. cdogg556

    cdogg556 Guru

    Joined:
    May 21, 2011
    Messages:
    6,903
    Likes Received:
    15,031
    Trophy Points:
    113
    Location:
    Folsom, Ca.
    My Bike(s):
    2009 Big Dog Mastiff, Chrome Package, DOC's ESC, 585 cam, VH Big Radius Exhaust, 2.5" fwd cntls.
    First Name:
    John
    I think you are right Eric, I can't see the lower bolt but you can see the upper one does have the locking tab on it though, shit I thought my chain was loose when I saw it, but this is "Really" loose!
    [​IMG]
     

    Attached Files:

  20. Th3InfamousI

    Supporting Member

    Joined:
    Sep 26, 2009
    Messages:
    10,378
    Likes Received:
    15,250
    Trophy Points:
    113
    Location:
    Texas
    My Bike(s):
    04 Ridgeback & 07 K9
    First Name:
    Eric
    His chain looks like a 70 year old women's set of boob's

    Sent from my 2PS64 using Tapatalk
     
    francoblay1 and cdogg556 like this.

Share This Page