Welcome to Our Community

Wanting to join the rest of our members? Feel free to sign up today.

Sign Up

Help

Discussion in 'Help Wanted' started by Gmutoagrsv, Nov 14, 2017.

  1. Gmutoagrsv

    Gmutoagrsv Active Member

    Joined:
    Jul 29, 2017
    Messages:
    251
    Likes Received:
    88
    Trophy Points:
    28
    Location:
    Reno nv
    My Bike(s):
    2006 mastiff
    First Name:
    Greg
    I have been reading more and more and somebody mentioned a breaker. where is that?


    Sent from my iPhone using Tapatalk
     
    chubs likes this.
  2. Th3InfamousI

    Supporting Member

    Joined:
    Sep 26, 2009
    Messages:
    10,615
    Likes Received:
    15,599
    Trophy Points:
    113
    Location:
    Texas
    My Bike(s):
    04 Ridgeback & 07 K9
    First Name:
    Eric
    Your head light wires should not go back to the coil...check again that's not right

    Sent from my 2PS64 using Tapatalk
     
  3. Gmutoagrsv

    Gmutoagrsv Active Member

    Joined:
    Jul 29, 2017
    Messages:
    251
    Likes Received:
    88
    Trophy Points:
    28
    Location:
    Reno nv
    My Bike(s):
    2006 mastiff
    First Name:
    Greg
    I’ll take a look tomorrow and try to trace the wires. And take pics. I did notice a junction block with 2 power wires coming out. 1 to the battery and not sure where the other goes. I figured that was probably it but I didn’t see any way to switch or reset it.
     
    chubs likes this.
  4. BWG56

    BWG56 Guru

    Joined:
    Jul 29, 2008
    Messages:
    21,039
    Likes Received:
    37,067
    Trophy Points:
    113
    Location:
    USA
    My Bike(s):
    Big Dog, SpyderF3
    First Name:
    Ker
    Its the little black thing on the side

    breaker.JPG IMG_0023.jpg
     
  5. Gmutoagrsv

    Gmutoagrsv Active Member

    Joined:
    Jul 29, 2017
    Messages:
    251
    Likes Received:
    88
    Trophy Points:
    28
    Location:
    Reno nv
    My Bike(s):
    2006 mastiff
    First Name:
    Greg
    Ok. I am baffled. I found a (jst)? Clip under the tank that was open with the same colors as the headlight. And it was the headlight side I looked closer and found a kinda open clip on the battery side. The reason I say “kinda” is it was capped off. I plugged it in and the headlight is working again but ?!?!?[​IMG][​IMG][​IMG]

    And the high beam indicator dimly blinks still.

    Sent from my iPhone using Tapatalk
     
  6. BWG56

    BWG56 Guru

    Joined:
    Jul 29, 2008
    Messages:
    21,039
    Likes Received:
    37,067
    Trophy Points:
    113
    Location:
    USA
    My Bike(s):
    Big Dog, SpyderF3
    First Name:
    Ker
    Check the connector that goes up to the Tach while your there, you might have a loose wire there also.
     
    dentdude36 likes this.
  7. Gmutoagrsv

    Gmutoagrsv Active Member

    Joined:
    Jul 29, 2017
    Messages:
    251
    Likes Received:
    88
    Trophy Points:
    28
    Location:
    Reno nv
    My Bike(s):
    2006 mastiff
    First Name:
    Greg
    Just pulled the tach apart and everything is clicked in. All other controls work running lights signals hazards horn and it runs ok. Just need to rejet and adjust carb. New pipe. But I have good power on the red wire good ground on black but nothing at all on the yellow. Please tell me I’m not gonna have to get into the wire loom itself. And on that note. How to I get the tank off this damn thing?


    Sent from my iPhone using Tapatalk
     
  8. Gmutoagrsv

    Gmutoagrsv Active Member

    Joined:
    Jul 29, 2017
    Messages:
    251
    Likes Received:
    88
    Trophy Points:
    28
    Location:
    Reno nv
    My Bike(s):
    2006 mastiff
    First Name:
    Greg
    Is there a relay that I am missing somewhere that switches from high beam to low beam?


    Sent from my iPhone using Tapatalk
     
  9. Unsprung

    Unsprung In the Potters hand...
    Supporting Member

    Joined:
    May 18, 2015
    Messages:
    1,311
    Likes Received:
    2,618
    Trophy Points:
    113
    Location:
    Ruskin, FL
    My Bike(s):
    08 K9, 06 Hayabusa, (wife's ride)
    First Name:
    Gerald
    dentdude36 and pknowles like this.
  10. Gmutoagrsv

    Gmutoagrsv Active Member

    Joined:
    Jul 29, 2017
    Messages:
    251
    Likes Received:
    88
    Trophy Points:
    28
    Location:
    Reno nv
    My Bike(s):
    2006 mastiff
    First Name:
    Greg
    I have it on my iPad phone and laptop. Been through it for other things but for this I can’t find anything close to what I’m looking for.


    Sent from my iPhone using Tapatalk
     
    Unsprung likes this.
  11. Gmutoagrsv

    Gmutoagrsv Active Member

    Joined:
    Jul 29, 2017
    Messages:
    251
    Likes Received:
    88
    Trophy Points:
    28
    Location:
    Reno nv
    My Bike(s):
    2006 mastiff
    First Name:
    Greg
    Still having issue. I’m thinking the high beam is on but the low isn’t. I’m gonna pull the loom apart at the ehc and check it there. Any more ideas?
     
  12. Gmutoagrsv

    Gmutoagrsv Active Member

    Joined:
    Jul 29, 2017
    Messages:
    251
    Likes Received:
    88
    Trophy Points:
    28
    Location:
    Reno nv
    My Bike(s):
    2006 mastiff
    First Name:
    Greg
    Still having issue. I’m thinking the high beam is on but the low isn’t. I’m gonna pull the the loom apart where it goes into the ehc and test it from there. See if it’s getting power from there.
     
  13. Gmutoagrsv

    Gmutoagrsv Active Member

    Joined:
    Jul 29, 2017
    Messages:
    251
    Likes Received:
    88
    Trophy Points:
    28
    Location:
    Reno nv
    My Bike(s):
    2006 mastiff
    First Name:
    Greg
  14. Gmutoagrsv

    Gmutoagrsv Active Member

    Joined:
    Jul 29, 2017
    Messages:
    251
    Likes Received:
    88
    Trophy Points:
    28
    Location:
    Reno nv
    My Bike(s):
    2006 mastiff
    First Name:
    Greg
    So I went out and was looking at it. I found 2 wiring diagrams the one for the bulldog has more detail. Looking at it all. It’s the high beam that’s out. I split the loom that goes into the backbone. Found 2 white wires. 1 is hot with the key on and the other isn’t. I went after the white wires since that’s what colours the options were and based off the diagram. I know one goes to the headlight and the other goes to the left hand control. I have a pic of something in the diagram and am wondering if there is any relays. In the second pic I noticed this thing on the ehc where the silicone has been slightly rubbed off. Also would I be able to look at the ehc and possibly see something fried on the circuit board?[​IMG][​IMG]


    Sent from my iPhone using Tapatalk
     
  15. Th3InfamousI

    Supporting Member

    Joined:
    Sep 26, 2009
    Messages:
    10,615
    Likes Received:
    15,599
    Trophy Points:
    113
    Location:
    Texas
    My Bike(s):
    04 Ridgeback & 07 K9
    First Name:
    Eric
    So you got 12v on the yellow wire and you cant get any voltage on white?

    There's really no way to remove the potting from the EHC to look inside. It is possible your high beam Relay is shot but I did you try jumping the pins in the hand control board to see if it's not the board?

    Sent from my 2PS64 using Tapatalk
     
  16. bdm7250

    bdm7250 Guru
    Supporting Member

    Joined:
    Jun 3, 2016
    Messages:
    6,625
    Likes Received:
    16,624
    Trophy Points:
    113
    Location:
    Hamilton Ontario Canada
    My Bike(s):
    2008 BD Mastiff 2008 AIH Slammer
    First Name:
    Doug
    Look up under the front of your tank, find the two bolts, loosen the front and remove the back.
    IMG_9508.JPG
    Put a 3/8" extension in the square at the front and turn.
    IMG_9507.JPG
    Pull the tank to the rear of the bike off the rear rubber mount.
    IMG_9509.JPG
    Before anything, drain your tank and remove crossover line.
     
  17. Gmutoagrsv

    Gmutoagrsv Active Member

    Joined:
    Jul 29, 2017
    Messages:
    251
    Likes Received:
    88
    Trophy Points:
    28
    Location:
    Reno nv
    My Bike(s):
    2006 mastiff
    First Name:
    Greg
    How do I get to my highbeam relay? I actually removed the entire hand control to see if that would change and it didn’t make any change at all
    Ya I wasn’t sure. It looked like something was rubbing on it and then when I wiped away that’s when I saw that little bare part.

    Bday. Ty. I pulled the bolts out of it and my issue was getting the front to turn so the bushings would release the tank. I didn’t even think about using a ratchet and turning it so thank you again
     
  18. Gmutoagrsv

    Gmutoagrsv Active Member

    Joined:
    Jul 29, 2017
    Messages:
    251
    Likes Received:
    88
    Trophy Points:
    28
    Location:
    Reno nv
    My Bike(s):
    2006 mastiff
    First Name:
    Greg
    Oh. I removed them both. I want to a shop today that deals with big dogs a lot. He kind of looked at me funny when I asked them about the high beam relay he said to his knowledge everything is controlled through the ehc
     
    chubs likes this.
  19. Mr. Wright

    Mr. Wright Guru
    Supporting Member

    Joined:
    Aug 27, 2012
    Messages:
    7,710
    Likes Received:
    10,860
    Trophy Points:
    113
    Location:
    Salem, Missouri
    My Bike(s):
    04 BD Chopper- 2002 1100 v-star
    First Name:
    Shannon
    Yes the high beam relay is part of the EHC.
     
    chubs likes this.
  20. Gmutoagrsv

    Gmutoagrsv Active Member

    Joined:
    Jul 29, 2017
    Messages:
    251
    Likes Received:
    88
    Trophy Points:
    28
    Location:
    Reno nv
    My Bike(s):
    2006 mastiff
    First Name:
    Greg
    so just replacing the ehc I’m screwed. No real way to determine if that is what is causing the issue
     
    chubs likes this.

Share This Page