Welcome to Our Community

Wanting to join the rest of our members? Feel free to sign up today.

Sign Up

Ignition questions...

Discussion in 'Technical' started by HellOnWheels, Mar 8, 2017.

  1. Ribs

    Ribs Live Free & Ride Hard
    Supporting Member

    Joined:
    Nov 24, 2016
    Messages:
    146
    Likes Received:
    206
    Trophy Points:
    43
    Location:
    Ward.AR
    My Bike(s):
    Bigdog Bulldog 2000
    First Name:
    Matt
    [​IMG]
    I've been reading other parts about this module and the talking about lights coming on and stuff like that this one? Nothing not a light comes on when I turn ignition on. We will see in couple days when this new module comes.


    Live Free and Ride Hard
     
    chubs likes this.
  2. chubs

    chubs Well-Known Member

    Joined:
    Sep 30, 2015
    Messages:
    4,493
    Likes Received:
    9,379
    Trophy Points:
    113
    Location:
    laf. indiana
    My Bike(s):
    2002 pitbull Prostreet -- 2003 XL 1200 C
    First Name:
    runky
    My eyes aint what they used to be, but up by the 6 pin connection, is that circuit board discolored ? Couldn't tell if its burned or just my eyes :oldconfused:
     
    Ribs likes this.
  3. 05chop

    05chop Well-Known Member

    Joined:
    Jul 17, 2007
    Messages:
    1,145
    Likes Received:
    118
    Trophy Points:
    63
    Location:
    wyoming
    My Bike(s):
    05 DT Chopper & 2010 Street Glide
  4. Ribs

    Ribs Live Free & Ride Hard
    Supporting Member

    Joined:
    Nov 24, 2016
    Messages:
    146
    Likes Received:
    206
    Trophy Points:
    43
    Location:
    Ward.AR
    My Bike(s):
    Bigdog Bulldog 2000
    First Name:
    Matt
    Yes thanks I've ordered a new module.
    If it don't light up like a V-twin Christmas tree I'm returning it and going with a whole new ignition.
    I've emailed thunder heart and called them. If I don't hear from them soon the answer is very clear they don't need my business.
    I'm done messing around with this. Thanks y'all for your help when the new module comes in I'll post my findings.

    Ribs


    Live Free and Ride Hard
     
    chubs likes this.
  5. FrankBDPS

    FrankBDPS Well-Known Member
    Supporting Member

    Joined:
    Sep 7, 2013
    Messages:
    3,235
    Likes Received:
    2,985
    Trophy Points:
    113
    Location:
    Navarre,Ohio
    My Bike(s):
    2ooo ProSport 1997 Honda Night Hawk
    First Name:
    Frank
    You do realize the unit you are holding in you're hand is not the ignition module don't you? That is the EHC or electronic harness controller. The ignition module is the metal one with the thunder heart shield and sword on it.

    Eric is right and that is why I asked about the micro relay. Some one else has been in there. She ain't no virgin any more. Don't get discouraged. When this is all over with you will love that bike.
     
    BadDawg Bill and chubs like this.
  6. Th3InfamousI

    Supporting Member

    Joined:
    Sep 26, 2009
    Messages:
    9,312
    Likes Received:
    13,896
    Trophy Points:
    113
    Location:
    Texas
    My Bike(s):
    04 Ridgeback & 07 K9
    First Name:
    Eric
    Haha..nice way to put it.

    No idea where that relay went still...but someone has been in there before messing around.



    Sent from my 2PS64 using Tapatalk
     
    chubs likes this.
  7. BigDogRick

    BigDogRick Active Member
    Supporting Member

    Joined:
    Sep 16, 2012
    Messages:
    449
    Likes Received:
    402
    Trophy Points:
    63
    Location:
    Phoenix, AZ
    My Bike(s):
    2000 Big Dog Vintage Classic, 2008 HD Fatboy
    First Name:
    Rick
    That relay is the primary power relay that acts like a master fuse. In my 2000 vintage, it sits behind and outside of the module but acts as a fuse if enough resistance builds up it opens up and disconnects power from the module (essentially everything). It is a very common single pole relay. I am surprised to see it plug into the module but do see how it could still perform its function. But as Eric and Frank are saying, the module has nothing to do with your ignition except the routing of the low voltage start button. The aluminum box can be replaced along with the cam sensor in the cone with a single S&S/Crane Hi-4N ignition that will perform beautifully and mount with the same doubly screws as your cam sensor.
     
    #87 BigDogRick, Mar 21, 2017
    Last edited: Mar 21, 2017
    BadDawg Bill and chubs like this.
  8. Th3InfamousI

    Supporting Member

    Joined:
    Sep 26, 2009
    Messages:
    9,312
    Likes Received:
    13,896
    Trophy Points:
    113
    Location:
    Texas
    My Bike(s):
    04 Ridgeback & 07 K9
    First Name:
    Eric
    Nice eye Rick I didn't even notice he had his finger where that relay went. I was looking at the tank pics and missed that haha.

    Isn't that the starter relay? Someone swapped it out I think. But as you mention not really anything to do with the ignition issue per say.

    It looks like he already ordered a new EHC so he will rule out the board with that I guess

    [​IMG]

    Sent from my 2PS64 using Tapatalk
     
    #88 Th3InfamousI, Mar 21, 2017
    Last edited: Mar 21, 2017
    chubs likes this.
  9. BadDawg Bill

    BadDawg Bill Well-Known Member

    Joined:
    Jun 16, 2014
    Messages:
    3,565
    Likes Received:
    6,568
    Trophy Points:
    113
    Location:
    Deltona fl
    My Bike(s):
    2008 Softail dexuxe customized
    First Name:
    Deplorable BadDawg Bill
    1++ S&S/Crane Hi-4N ignition and fergetaboutit.....
     
    Ribs and chubs like this.
  10. Hirter6Pack

    Hirter6Pack Not Quite A Guru

    Joined:
    Oct 31, 2015
    Messages:
    2,063
    Likes Received:
    4,926
    Trophy Points:
    113
    Location:
    Saint Joseph Mo
    My Bike(s):
    2004 Mastiff
    First Name:
    Rick
    Read page 11 chapter 4.1
    We do not want that thing lighting up like a Christmas tree. IMG_1557.PNG
    Although a new EHC may solve your problems. If it is like the 04 the EHC supplies voltage to the thunder heart ignition module ( that little silver box at the top of the tank) it needs at least 8volt for that module to work.
    When my EHC failed it had the power on LED illuminated That's a good thing. No other LED was illuminated that's a good thing. Problem was Thunderheart ignition module at the top of the tank with the one LED (that little silver box) never flashed while cranking. So with an amp meter and a little sewing needle I figured the EHC was only putting out 6volts. Damn the bad luck. Now to test that theory I could get the bike to run by supplying 12 volts with that same sewing needle. Fired right up.
    Shit
    Replaced the EHC. All is well.


    IMG_1099.PNG
    This is the thunderheart ignition module. With the little LED by the data port. It should flash while cranking and stay on while running providing the cam sensor is good and you have enough supply voltage from the EHC.
     
    Ribs and chubs like this.
  11. Ribs

    Ribs Live Free & Ride Hard
    Supporting Member

    Joined:
    Nov 24, 2016
    Messages:
    146
    Likes Received:
    206
    Trophy Points:
    43
    Location:
    Ward.AR
    My Bike(s):
    Bigdog Bulldog 2000
    First Name:
    Matt
    Ok I'm not getting any red LED now,. The light.. it use to come on when I turned on the ignition.
    I will have the other module in couple days thanks for the info.
    I will go threw the manual and re read your post and see what I can figure out.


    Live Free and Ride Hard
     
    chubs likes this.
  12. FrankBDPS

    FrankBDPS Well-Known Member
    Supporting Member

    Joined:
    Sep 7, 2013
    Messages:
    3,235
    Likes Received:
    2,985
    Trophy Points:
    113
    Location:
    Navarre,Ohio
    My Bike(s):
    2ooo ProSport 1997 Honda Night Hawk
    First Name:
    Frank
    At first I did not remember that relay on mine and thought it was separate from the EHC. These 12 hour shifts seven days a week are burning up what few brain cells I have left. He will know more about his bike than most guys when he is done with it. Keep up the good work. Did you get you're bike running Rick?
     
    Ribs and chubs like this.
  13. BigDogRick

    BigDogRick Active Member
    Supporting Member

    Joined:
    Sep 16, 2012
    Messages:
    449
    Likes Received:
    402
    Trophy Points:
    63
    Location:
    Phoenix, AZ
    My Bike(s):
    2000 Big Dog Vintage Classic, 2008 HD Fatboy
    First Name:
    Rick
    Not yet. Its been a very spotty search for the gremlin since eliminating the big and obvious.
     
    Ribs and chubs like this.
  14. Unsprung

    Unsprung Active Member

    Joined:
    May 18, 2015
    Messages:
    687
    Likes Received:
    1,491
    Trophy Points:
    93
    Location:
    Ruskin, FL
    My Bike(s):
    03 Pitbull, 06 Hayabusa
    First Name:
    Gerald
    The EHC you pulled the relay from is an upgrade from the BDM unit. I Purchased and installed a Big Dog ready Thunderheart EHC from Curtis at Wild Steed Worx, same one in your pic. Some of the wires had to be changed from the stock location so if this was done on your bike keep in mind the harness is not going to match the original schematic. I lost my IG module, (with sword and shield), and cam sensor, also replaced through WSW. Have not had any ignition issues since. Seems your IG module may be going bad or the cam sensor is shot.
     
    Ribs and chubs like this.
  15. Ribs

    Ribs Live Free & Ride Hard
    Supporting Member

    Joined:
    Nov 24, 2016
    Messages:
    146
    Likes Received:
    206
    Trophy Points:
    43
    Location:
    Ward.AR
    My Bike(s):
    Bigdog Bulldog 2000
    First Name:
    Matt
    Yeah I'm going to take out the cam sensor and test it I already bought the S&S Intelligent Spark Technology High Output Single Fire Ignition Coil.
    So I'm going to get the S&S/Crane Hi-4N ignition module.
    That should sort things out.


    Live Free and Ride Hard
     
    chubs and Unsprung like this.
  16. Ribs

    Ribs Live Free & Ride Hard
    Supporting Member

    Joined:
    Nov 24, 2016
    Messages:
    146
    Likes Received:
    206
    Trophy Points:
    43
    Location:
    Ward.AR
    My Bike(s):
    Bigdog Bulldog 2000
    First Name:
    Matt
    Yeah mine does nothing, it use too light up and flash when cranking. But I guess it decided to pack it in.

    I will be getting the HI-4N ignition module on the 28th
    Hope I don't have to Shell out much more with the two coils and the new thunder heart module and the HI-4N ignition almost 750.00 and allot of wasted time not enjoying my Beast.

    I appreciate all the help and advice y'all have given and shared with me.

    There is a bike show I wanted to put the Bull Dog into but I'm not liking the time factor the rally is for two days and the bike show is on the saterday 1st of April.
    I don't like my chances of getting it ready.
    Looks like I'll have to put my Dyna Low Rider in there in stead.

    If any of you are going to the Cabot.AR spring fling. You'll find me near the B.A.C.A tent.

    Ribs

    Live Free and Ride Hard
     
    chubs likes this.
  17. Ribs

    Ribs Live Free & Ride Hard
    Supporting Member

    Joined:
    Nov 24, 2016
    Messages:
    146
    Likes Received:
    206
    Trophy Points:
    43
    Location:
    Ward.AR
    My Bike(s):
    Bigdog Bulldog 2000
    First Name:
    Matt
    [​IMG]
    Got the S&S Hi-4N ignition in finally, going to be using the duel fire coil.

    It's not going to run as good as the single fire coil from what I'm reading but it will have to do until I can figure out how I'm going to mount the bigger single fire coil behind the Bigdog billet cover.

    Still wiring it all up. I know I already got a couple questions for you guys

    I'm reading about VOES the manual says if a VOES is not used the Violet wire may be grounded to use full Advance curve or taped up to use the retarded curve depending on the application and timing requirements of the engine.
    ?
    Hope y'all are doing good.
    Ribs

    Live Free and Ride Hard
     
    chubs likes this.
  18. FrankBDPS

    FrankBDPS Well-Known Member
    Supporting Member

    Joined:
    Sep 7, 2013
    Messages:
    3,235
    Likes Received:
    2,985
    Trophy Points:
    113
    Location:
    Navarre,Ohio
    My Bike(s):
    2ooo ProSport 1997 Honda Night Hawk
    First Name:
    Frank
    Bike shows are nice but they are a huge waste of riding time. I used to go to them and finally woke up to the fact that I was missing seat time while standing around doing nothing. Keep up the good work.
     
    chubs and Ribs like this.
  19. Ribs

    Ribs Live Free & Ride Hard
    Supporting Member

    Joined:
    Nov 24, 2016
    Messages:
    146
    Likes Received:
    206
    Trophy Points:
    43
    Location:
    Ward.AR
    My Bike(s):
    Bigdog Bulldog 2000
    First Name:
    Matt
    My Chopper is alive and running.
    That was too easy.

    It's a 107 S&S

    The settings I got on the HI-4N

    Mode 5

    Advance rate 7

    Rev limit 5500

    Any suggestions?[​IMG]


    Live Free and Ride Hard
     
    Hirter6Pack and chubs like this.
  20. Ribs

    Ribs Live Free & Ride Hard
    Supporting Member

    Joined:
    Nov 24, 2016
    Messages:
    146
    Likes Received:
    206
    Trophy Points:
    43
    Location:
    Ward.AR
    My Bike(s):
    Bigdog Bulldog 2000
    First Name:
    Matt
    I'm not sure if I need to mess with the timing adjustment the idle seemed a tad low with the new ignition. Idled it up a bit and it seems ok.
    Any suggestions on setting the timing correctly or does the Hi-4N do that electronically ?


    Live Free and Ride Hard
     
    BigDogRick and chubs like this.

Share This Page