Welcome to Our Community

Wanting to join the rest of our members? Feel free to sign up today.

Sign Up

New Battery but Bike Wont Turn on!!!

Discussion in 'Technical' started by Jeffrey Leatherwood, Jun 9, 2018.

  1. lonerider101

    lonerider101 Member

    Joined:
    Apr 5, 2014
    Messages:
    143
    Likes Received:
    100
    Trophy Points:
    43
    My Bike(s):
    1972 1000cc Harley XLCH Sportster, 1986 Harley Wide Glide, 2005 Big Dog Chopper
    I also hav an '05 Chopper(DT version). Yur 1st pic must be yur EHC, but not BDM stock version - as I'm running. Mayb Paul or someone else can enlighten us on type u hav in 1st pic.
     
    Jeffrey Leatherwood likes this.
  2. pauldeepsea

    pauldeepsea Well-Known Member

    Joined:
    Jun 15, 2008
    Messages:
    4,633
    Likes Received:
    5,262
    Trophy Points:
    113
    Location:
    California
    My Bike(s):
    2004 Pitbull/ridgeback , 2006 big bear sled 300
    First Name:
    Paul
    Do you have any pics of your ehc? It is the box located in your battery Tray.



    Sent from my iPhone using Tapatalk
     
    Jeffrey Leatherwood likes this.
  3. lonerider101

    lonerider101 Member

    Joined:
    Apr 5, 2014
    Messages:
    143
    Likes Received:
    100
    Trophy Points:
    43
    My Bike(s):
    1972 1000cc Harley XLCH Sportster, 1986 Harley Wide Glide, 2005 Big Dog Chopper
    Paul, look at the 1st pic he posted of module in battery box area & tell us what it is - brand, etc.
     
    Jeffrey Leatherwood likes this.
  4. pauldeepsea

    pauldeepsea Well-Known Member

    Joined:
    Jun 15, 2008
    Messages:
    4,633
    Likes Received:
    5,262
    Trophy Points:
    113
    Location:
    California
    My Bike(s):
    2004 Pitbull/ridgeback , 2006 big bear sled 300
    First Name:
    Paul
    This to me does not sound like an ehc issue. Wouldn’t hurt to check the wiring harness to the controls either. Loose connection or frayed connecting in the controls would cause the turn signals, horn etc not to work.
    With ehc issues the dash, light etc tend not to work.not always but ..


    Sent from my iPhone using Tapatalk
     
    Jeffrey Leatherwood likes this.
  5. pauldeepsea

    pauldeepsea Well-Known Member

    Joined:
    Jun 15, 2008
    Messages:
    4,633
    Likes Received:
    5,262
    Trophy Points:
    113
    Location:
    California
    My Bike(s):
    2004 Pitbull/ridgeback , 2006 big bear sled 300
    First Name:
    Paul
    That is not the ehc, the ehc is the box that the main wiring harness plugs into. That is his ignition module.


    Sent from my iPhone using Tapatalk
     
    Jeffrey Leatherwood likes this.
  6. pauldeepsea

    pauldeepsea Well-Known Member

    Joined:
    Jun 15, 2008
    Messages:
    4,633
    Likes Received:
    5,262
    Trophy Points:
    113
    Location:
    California
    My Bike(s):
    2004 Pitbull/ridgeback , 2006 big bear sled 300
    First Name:
    Paul
    Ehc’s look like this, different models for year groups [​IMG]


    Sent from my iPhone using Tapatalk
     
    Jeffrey Leatherwood likes this.
  7. lonerider101

    lonerider101 Member

    Joined:
    Apr 5, 2014
    Messages:
    143
    Likes Received:
    100
    Trophy Points:
    43
    My Bike(s):
    1972 1000cc Harley XLCH Sportster, 1986 Harley Wide Glide, 2005 Big Dog Chopper
    Paul, he posted 2 pics(1 over other). The bottom(2nd) pic is ign module, but above pic is what - its in battery area with lights & a harness barely visible. Did pics come thru on yur screen?
     
    Jeffrey Leatherwood likes this.
  8. Jeffrey Leatherwood

    Joined:
    Feb 7, 2018
    Messages:
    26
    Likes Received:
    10
    Trophy Points:
    3
    Location:
    College Station TX
    My Bike(s):
    2005 Big Dog Chopper, 2018 TW200, Mini Bike, PW50
    First Name:
    Jeff
    Here's what I'm working with: IMG_9929.jpg IMG_9930.jpg IMG_9932.jpg IMG_9933.jpg IMG_9934.jpg IMG_9931.jpg
     
  9. pauldeepsea

    pauldeepsea Well-Known Member

    Joined:
    Jun 15, 2008
    Messages:
    4,633
    Likes Received:
    5,262
    Trophy Points:
    113
    Location:
    California
    My Bike(s):
    2004 Pitbull/ridgeback , 2006 big bear sled 300
    First Name:
    Paul
  10. pauldeepsea

    pauldeepsea Well-Known Member

    Joined:
    Jun 15, 2008
    Messages:
    4,633
    Likes Received:
    5,262
    Trophy Points:
    113
    Location:
    California
    My Bike(s):
    2004 Pitbull/ridgeback , 2006 big bear sled 300
    First Name:
    Paul
    The green light on the wp unit tells me that it is working. Check the things I mentioned previously


    Sent from my iPhone using Tapatalk
     
  11. Jeffrey Leatherwood

    Joined:
    Feb 7, 2018
    Messages:
    26
    Likes Received:
    10
    Trophy Points:
    3
    Location:
    College Station TX
    My Bike(s):
    2005 Big Dog Chopper, 2018 TW200, Mini Bike, PW50
    First Name:
    Jeff
    Here’s a better pic of harness connectors.
     

    Attached Files:

  12. pauldeepsea

    pauldeepsea Well-Known Member

    Joined:
    Jun 15, 2008
    Messages:
    4,633
    Likes Received:
    5,262
    Trophy Points:
    113
    Location:
    California
    My Bike(s):
    2004 Pitbull/ridgeback , 2006 big bear sled 300
    First Name:
    Paul
    Aftermaket wire plus unit, it was the first alternative ehc unit. They are no longer in business but the green light on the unit means it is working. I am leaning towards something in his hand control wiring harness


    Sent from my iPhone using Tapatalk
     
  13. lonerider101

    lonerider101 Member

    Joined:
    Apr 5, 2014
    Messages:
    143
    Likes Received:
    100
    Trophy Points:
    43
    My Bike(s):
    1972 1000cc Harley XLCH Sportster, 1986 Harley Wide Glide, 2005 Big Dog Chopper
    Thanks, I knew u'd know plus u enlightened me on what they look like. Also mayb u or someone w/knowledge can help Jeffrey with functions of its lights & testing. But as u stated earlier I'd definitely ck right side switch board 1st. Thanks again.
     
  14. pauldeepsea

    pauldeepsea Well-Known Member

    Joined:
    Jun 15, 2008
    Messages:
    4,633
    Likes Received:
    5,262
    Trophy Points:
    113
    Location:
    California
    My Bike(s):
    2004 Pitbull/ridgeback , 2006 big bear sled 300
    First Name:
    Paul
    I would look at the wiring harness that controls both the left and right controls. Could be the board but due to the fact that the left turn signal and horn don’t work either, I am leaning towards the wiring harness


    Sent from my iPhone using Tapatalk
     
  15. Jeffrey Leatherwood

    Joined:
    Feb 7, 2018
    Messages:
    26
    Likes Received:
    10
    Trophy Points:
    3
    Location:
    College Station TX
    My Bike(s):
    2005 Big Dog Chopper, 2018 TW200, Mini Bike, PW50
    First Name:
    Jeff
    I’ll deiiassemble hand control system this evening. Kids are begging to get in pool. Thanks guys I’ll post follow up tonight!
     
    HMAN likes this.
  16. pauldeepsea

    pauldeepsea Well-Known Member

    Joined:
    Jun 15, 2008
    Messages:
    4,633
    Likes Received:
    5,262
    Trophy Points:
    113
    Location:
    California
    My Bike(s):
    2004 Pitbull/ridgeback , 2006 big bear sled 300
    First Name:
    Paul
    Okay check the harness that runs up the back bone and connects the controls from the wire plus unit. Look for bare wires, also check the jst connections make sure all the wires are locked into the jst connections. Disconnect the jst and look for broke pins use electronics cleaner and die electric grease and reconnect. From there check the wiring harness for continuity.


    Sent from my iPhone using Tapatalk
     
  17. pauldeepsea

    pauldeepsea Well-Known Member

    Joined:
    Jun 15, 2008
    Messages:
    4,633
    Likes Received:
    5,262
    Trophy Points:
    113
    Location:
    California
    My Bike(s):
    2004 Pitbull/ridgeback , 2006 big bear sled 300
    First Name:
    Paul
    Does the green light on the module light up when the key is turned on? I thought I saw that it was lit up but just verifying


    Sent from my iPhone using Tapatalk
     
  18. Jeffrey Leatherwood

    Joined:
    Feb 7, 2018
    Messages:
    26
    Likes Received:
    10
    Trophy Points:
    3
    Location:
    College Station TX
    My Bike(s):
    2005 Big Dog Chopper, 2018 TW200, Mini Bike, PW50
    First Name:
    Jeff
    No, I’m getting 3 of 6 on the board lights but the black box module that has 1 light and 1 bolt running thru it does not light up
     
  19. dentdude36

    dentdude36 Banned

    Joined:
    Nov 9, 2015
    Messages:
    424
    Likes Received:
    778
    Trophy Points:
    113
    Location:
    Upstate NY (suburbs of Buffalo)
    My Bike(s):
    2007 K9
    First Name:
    kevin
    If the wire plus is shot then get D O C S esc
     
    bdm7250, BWG56 and cdogg556 like this.
  20. Hirter6Pack

    Hirter6Pack Not Quite A Guru
    Supporting Member

    Joined:
    Oct 31, 2015
    Messages:
    2,349
    Likes Received:
    5,085
    Trophy Points:
    113
    Location:
    Saint Joseph Mo
    My Bike(s):
    2004 Mastiff
    First Name:
    Rick

Share This Page