Welcome to Our Community

Wanting to join the rest of our members? Feel free to sign up today.

Sign Up

oil press sensor?

Discussion in 'Help Wanted' started by 05 old dog, Feb 22, 2017.

  1. 05 old dog

    05 old dog Well-Known Member

    Joined:
    Nov 19, 2010
    Messages:
    1,153
    Likes Received:
    173
    Trophy Points:
    63
    Location:
    liberal kansas
    My Bike(s):
    05 bulldog
    First Name:
    billy
    how do these things work? when you get oil press. does it ground and turn oil light off...cant get my oil light to come on at all......PDM wiring, dakota digital speedo, it use to work...then worked sparaticly..now not at all....i have installed 2 different new ones....same results. i have an oil press guage and run 40-50# on start up but after 30 min of riding it reads just off the 0 peg...gotta get this low oil press light working.
     
    chubs likes this.
  2. Th3InfamousI

    Supporting Member

    Joined:
    Sep 26, 2009
    Messages:
    9,313
    Likes Received:
    13,896
    Trophy Points:
    113
    Location:
    Texas
    My Bike(s):
    04 Ridgeback & 07 K9
    First Name:
    Eric
    Just cause the gauge reads 0 doesn't mean it's right. Your oil light only comes on with like around 2 PSI. Doubtful you are ever that low.




    Sent from my 2PS64 using Tapatalk
     
    chubs likes this.
  3. 05 old dog

    05 old dog Well-Known Member

    Joined:
    Nov 19, 2010
    Messages:
    1,153
    Likes Received:
    173
    Trophy Points:
    63
    Location:
    liberal kansas
    My Bike(s):
    05 bulldog
    First Name:
    billy
    yes sir...but my light does not come on at all now...even with key on and bike not started....trying to figure out why....maybe led out in tach ring?
     
    chubs likes this.

Share This Page