Welcome to Our Community

Wanting to join the rest of our members? Feel free to sign up today.

Sign Up

Starter System

Discussion in 'Technical' started by Raywood, Dec 21, 2009.

  1. roughrider

    roughrider Member

    Joined:
    Feb 10, 2011
    Messages:
    66
    Likes Received:
    1
    Trophy Points:
    0
    Location:
    UK
    My Bike(s):
    Big Dog K9 EFi/K9 Carb & Aprilia Tuono Factory
    First Name:
    Paul
    Please help!! Got an 09 K9 in the uk. Only done 380 miles, but its never run since i got it. Starter won't turn the engine over. Battery looks good, with green light on battery conditioner. The solenoid clicks in momentarily, then releases before engine cranks. I can turn engine over by hand in 6th gear using the front pulley, but the starter just doesn't want to turn, even with booster cables attached. The copper lead from solenoid to starter looks like its been hot, with the black rubber sheath broken up. I have tried to disassemble the starter, but the main body won't separate, and a little lug has fallen out of the side of the starter. Any advice/opinions welcome. Thank you guys!!!!
     
  2. timbo-k9

    timbo-k9 New Member

    Joined:
    Apr 13, 2008
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    England
    My Bike(s):
    K9
    First Name:
    Tim
    Hi, the same thing has just happened to me on my 2006 K9, the starter has been working fine and then all of the sudden: Clunk and that was it!! Tim.
     
  3. timbo-k9

    timbo-k9 New Member

    Joined:
    Apr 13, 2008
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    England
    My Bike(s):
    K9
    First Name:
    Tim
    Hi, I brought and imported my 2006 K9 from new when they first came out and after years of problems with electrics on it I dumped the original wiring and had it rewired minus the ever troubling EHC and since I have had no where near as many problems! Tim. (England)
     
  4. francoblay1

    francoblay1 The Spaniard

    Joined:
    Aug 14, 2011
    Messages:
    15,176
    Likes Received:
    12,356
    Trophy Points:
    113
    Location:
    L´Escala, 17130 Spain
    My Bike(s):
    K9 (2006)
    First Name:
    Franco
    Hi Tim,

    I do see you´ve been a member since 2008... but I did not see an Intro... :D

    Check these two links out:

    1. INTRO

    2. MEMBERS EUROPE

    Cheers Mate. :cheers:
     
  5. francoblay1

    francoblay1 The Spaniard

    Joined:
    Aug 14, 2011
    Messages:
    15,176
    Likes Received:
    12,356
    Trophy Points:
    113
    Location:
    L´Escala, 17130 Spain
    My Bike(s):
    K9 (2006)
    First Name:
    Franco
  6. DocScot

    DocScot New Member

    Joined:
    Apr 29, 2014
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    My Bike(s):
    2002 Pitbull
    Starter or the coil?

    Great article and I just want to make sure before I start taking things apart.
    I'm guessing a bad starter but I need a second opinion. I have a video if anyone wants to look it, I will have to email it to you.
    It acts like the battery just doesn't have enough power to turner it all the way. It's a brand new battery.
     

Share This Page