Welcome to Our Community

Wanting to join the rest of our members? Feel free to sign up today.

Sign Up

Stop and turn problem

Discussion in 'General' started by tomcat, Jul 4, 2017.

  1. tomcat

    tomcat New Member

    Joined:
    Jun 10, 2011
    Messages:
    8
    Likes Received:
    2
    Trophy Points:
    3
    Location:
    Covington, Washington
    My Bike(s):
    2003 BigDog chopper
    I have a 03 chopper and when I start it up, the turn, stop and speedo don't work. But they do when it is not running but ignition on. Any ideas?
     
    chubs likes this.
  2. cdogg556

    cdogg556 Guru

    Joined:
    May 21, 2011
    Messages:
    6,974
    Likes Received:
    15,374
    Trophy Points:
    113
    Location:
    Folsom, Ca.
    My Bike(s):
    2009 Big Dog Mastiff, Chrome Package, DOC's ESC, 585 cam, VH Big Radius Exhaust, 2.5" fwd cntls.
    First Name:
    John
    Well that's a new one that I've never heard before, I wonder if you have a loose connection somewhere and the vibration of the bike while running is enough to cause the connection to separate? Other than that I'm not sure since you say it starts and runs fine, don't really sound like an EHC issue.
     
    bigkelk9 and chubs like this.
  3. woodbutcher

    woodbutcher Mr. Old Fart member #145
    Staff Member Supporting Member

    Joined:
    Aug 16, 2007
    Messages:
    10,313
    Likes Received:
    3,751
    Trophy Points:
    113
    Location:
    hilton head is., sc
    My Bike(s):
    black cherry '07 K9
    First Name:
    Tom
    ????? ignition switch ?????? possibly chaffed wire down the backbone.
     
    BadDawg Bill, bigkelk9 and chubs like this.
  4. Mr. Wright

    Mr. Wright Guru
    Supporting Member

    Joined:
    Aug 27, 2012
    Messages:
    6,981
    Likes Received:
    9,205
    Trophy Points:
    113
    Location:
    Salem, Missouri
    My Bike(s):
    03 BD Chopper - 04 BD Chopper- 2002 1100 v-star
    First Name:
    Shannon
    03 had a recall years ago. The problem was that the seat was pushing down on the EHC and causing pinched wire problems. Their fix was to put a big tie strap horizontally around the plastic box that holds the EHC, to keep the EHC in place and not crush the wires. I've fixed two this way and it cured the problem.
     
  5. woodbutcher

    woodbutcher Mr. Old Fart member #145
    Staff Member Supporting Member

    Joined:
    Aug 16, 2007
    Messages:
    10,313
    Likes Received:
    3,751
    Trophy Points:
    113
    Location:
    hilton head is., sc
    My Bike(s):
    black cherry '07 K9
    First Name:
    Tom
    well, just keep this little tidbit to yourself why don't you. this is a good little bit of info to be aware of. thank you, Shannon !!!!!!!! don't care what anybody else says, you are good to have around. :cheers:
     
  6. tomcat

    tomcat New Member

    Joined:
    Jun 10, 2011
    Messages:
    8
    Likes Received:
    2
    Trophy Points:
    3
    Location:
    Covington, Washington
    My Bike(s):
    2003 BigDog chopper
    was checking all this info I received and now the break lights don't work at all!
     
    chubs likes this.
  7. JR03CHOPPER

    JR03CHOPPER Well-Known Member
    Supporting Member

    Joined:
    Oct 24, 2011
    Messages:
    2,084
    Likes Received:
    2,243
    Trophy Points:
    113
    Location:
    Orlando, FL
    My Bike(s):
    2003 Big Dog Chopper, 2007 Big Dog K9
    First Name:
    JR
    Also check your wires under the rear fender. The tire can wear the channel built into the fiberglass. This will cause the wire to make contact and eventually short out. Might not be the root of the problem with your controls but could be a reason for your brake lights. I used plumbers cement to make a new channel for the wire and it has held up well.
     
    chubs likes this.

Share This Page